from our blog

WordPress 5.5 Update Issues, Resolution, and File Manager Vulnerability

Posted by Simranjeet Singh

WordPress, Development, security threat

WordPress updates are tough to handle. Whenever WordPress releases an update, we get to know what new can go wrong with our websites. This time, the WordPress 5.5 update is breaking the websites. And, the memes were anticipated after the update release.


Here’s my favorite – WordPress 5.5 Fix – downgrade it to 5.4.2. This also was one of the topics on WordPress’s official forum.

 

WordPress CMS holds around 60% market share, making it one of the most used CMS in the world. Computan’s clientele also includes WordPress users.

 

Here are a few screenshots of issues people are facing after the WordPress 5.5 update.

 

WordPress-5-5-WordPress-org

 

Media-problem-after-WP-5-5-Update-WordPress-org

image source

 

Issues in the drop down menu, issues in showing pop-ups, issues in the slideshow, issues in the media gallery, and whatnot left the WordPress users frustrated. A few even got a broken website admin panel.

 

A few hiccups in the process are understandable. But, in the case of WordPress, the issues escalate to another level. It is because most of the features and functionalities are achieved by plugins and during an update, all the outdated plugins just stop working. And, this time as well, the update has removed all the plugins and themes that use jQuery Migrate. This has affected thousands of websites that use this jQuery-migrate in their plugins or themes creating chaos on the websites.

 

WordPress introduced 5.5 update without jQuery Migrate – a JavaScript library. jQuery Migrate was responsible for older code to function on WordPress.

 

WordPress users who still use older WordPress themes and plugins are facing the most of the problems because the bridge i.e. jQuery Migrate which was bridging the gap is no longer there. The old plugins and themes would have performed if there was a jQuery Migrate in this WordPress 5.5 update.

How to fix jQuery Migrate Issues

If jQuery Migrate is causing some of your plugins to not work, then update that plugin. If the newer version isn’t available, you should install another newer plugin. Older plugins abandoned by their developers are a huge security risk. So, regardless of the jQuery migrate issue, make it a standard practice to update the plugin that is still managed and maintained by their developers.


To tackle the situation, WordPress has released a plugin to restore the jQuery Migrate JavaScript library. This makes your website fully functional again.

 

Download WordPress Enable jQuery Migrate Helper

 

More recently, on September 1st, 2020, nearly 700,000 WordPress users got affected by the File Manager Plugin. The File Manager plugin allows WordPress users to manage the files on their site.

 

WordPress File Manager Issue

image source

 

The WordPress Threat intelligence team was notified of the exposure of the plugin to unauthenticated users. The File Manager has almost 700,000 downloads. The risk with the plugin was that the unauthenticated users could execute the commands and insert malicious files on the target site. This vulnerability risked all 700,000 plugin users.


The safety patch to protect the users from this vulnerability was released on September 1st, 2020. So, it is requested to the user to install the latest version of the plugin.

 

Wordfence, free + premium users are protected against the risk as the built-in Wordfence firewall protection hen optimized, protects the users from such attacks.

Simranjeet Singh

Written by Simranjeet Singh

Writer | HubSpot Certified Inbound Marketer and Content Marketer